Born Geek

Contact Me

Special Note on Firefox 57+

Both CoLT and Googlebar Lite no longer work with Firefox, beginning in version 57.0. Please note that there are no plans to update either extension at this time.

Use the following form to contact me directly. Although I cannot always guarantee a reply, I do read each and every message. Fields marked with a red asterisk (*) are required.

*
*
*

Please note that any HTML or XUL code you supply in your message will be removed.
*
(This confirms you're not a robot)